R - Exercises + June 12 Notes and Recording

Hi All,

Hope you’re doing fine! Here is the link to the folder containing the notes and recording of June 12.

NB:

  • NEXT WEEK WE WONT HAVE ANY R TRAINING

  • In the notes you will find three small exercises

  • It is mandatory to them and upload your answers in the following folder! ONLY PDF files.

  • Deadline: 18 June 2020 11pm PDT

Please don’t cheat! we are here to learn and you won’t be graded. So be creative especially in the third exercise

If you have any question, don’t hesitate to post it here or send me a private message.

See you soon!

Yves

Hi!

This is probably obvious but I just wanted to make sure. For the second exercise, when it says to explore the results for: “Mov10_knockdown comparison to control”, is that referring to the sampletype_MOV10_knockdown_vs_control in our dds data? Thank you!

Yes @Anca

1 Like

IMPORTANT

Hi All,

I saw that some of you had some issues installing apeglm and other packages. The problem is that you’re using the R version 4.0.1. This version is not compatible with many packages from Bioconductor.

You need to install R version 4.0.0.

MAC: https://drive.google.com/open?id=1jaKnxrS4GEXbG4KS0whPh34DBDCqjS-O

WINDOWS: https://drive.google.com/open?id=1IBcm8jKX2IYzkQ0ysHzhzsye6MeNff14

Hi Yves! I’m using R version 4.0.0 but I still have difficulty installing the apeglm package. It gives a warning like this:


Should I try some other versions of R?

Hi Chloe. I ran into the same problem and I typed the code below into the terminal. After doing this, I used the install.packages(“apeglm”).
library
I found it from this link:

That worked! Thanks Yoga!

Sorry I have another question! I tried to upload my pdf file to the folder but it says I don’t have permission to do so. Could you please open up the permission for us to upload? Thanks a lot!

Hey, I have the same problem with installing apeglm. I used the same website as Yoga, and that code seems to install the package. However, when I do install.packages(“apeglm”) after that, it still says:

Warning in install.packages :
package ‘apeglm’ is not available (for R version 4.0.0)

I have tried various ways to install it and searched different things, but I cannot get the code needed to answer the question because of the apeglm installation. Does anyone have suggestions?

I am having the same issue.

Hi Everyone,

I have updated the permissions, now you can upload your work.

Yves

Hi @Kristen_15, have you tried to install it using Bioconductor?

Yes, I did the code from the Bioconductor website that is linked above.