Everyone please mention your Discourse installation problems here or direct message us! We will help :)

Note: If anyone is not comfortable posting here, you can message me directly also. No problem.

Note: Mac Users can message @Vrinda_Jain and Ubuntu users can message me @Sai_Likhith.

Hello everyone :slight_smile: ,
Hope you are all doing well. It will be great if we can get all the installation problems solved and out of the way before the start of the session. But no worries if you don’t have the time now. Please respond whenever you are free and we will help you set up when the June 1st session starts :raised_hands:

The people who had a problem installing Discourse, please do post the error screenshots to us. We will compile different types of issues and consult with the project industry expert if required and ensure that no one has a problem by June 1st i.e., the start of internship.

We are here to help everyone’s instance up and running by the time internship onboards. So, please do mention your problems !!!

Update:
Here is the documentation for step by step procedure while installation.


Mac issues- Contact @Vrinda_Jain or tag us here in your comment
Ubuntu issues- Contact @Sai_Likhith or tag us here in your comment.

Hi Guys,
I need some help here.
I installed discourse with this command:
"bash <(wget -qO- https://raw.githubusercontent.com/techAPJ/install-rails/master/linux)"
then after the installation, before I clone the discourse repository on my local machine, I tried to start the postgress sql with this command “sudo service postgresql start” but I am getting an error that says: “postgresql: unrecognized service”. Then I run sudo app-get install postgresql which I think might solve the problem but then I get another error: "chmod: changing permissions of ‘/var/run/postgresql’: Operation not permitted"

By the way, I am using Ubuntu on window.

Hi, I am using Mac system and am trying to install discourse from the instructions from this website:(https://meta.discourse.org/t/beginners-guide-to-install-discourse-on-macos-for-development/15772).

When I am trying to install the needed gems using the command "bundle install", I see the error message:


When I follow the two commands in the terminal shown above, I received the following message:

Please help! Thanks in advance.

Hey @Chris_Shen

I had the same issue.
Try the following commands, these worked for me.

rvm install ruby-2.6
gem install bundler:2.1.4
bundle update --bundler

and finally
bundle install

Let me know if it works for you.

This works! Thank you so much!

@tiatmehta is taking care of Ubuntu machines!
I’m mentioning here, she might have an answer for you.

Hi,
When I was running
bundle exec rake autospec
I didn’t pass all tests, and I received the following message:


Thanks in advance

Hey Chris, were you able to open the localhost in browser and see the discourse there?

Hey @aayodipe, I assume its a typing mistake for its sudo apt-get if I’m not wrong, in that case, I would suggest first clone and change the directory and follow the installation instructions, it will work. If not, please mention here.

@Sai_Likhith Yes, now I can access the localhost in browser and I have created an account. Does that mean I can disregard the previous error messages?

@Sai_Likhith_K I still have issues with discourse installation. Although I am still trying to debug it. Attached is my screenshot

@Chris_Shen I think you are all set up. Try going forward with the process.

I’ve been stuck here for a long time. Any suggestions?

Hello busy people,
Here I am with a new Documentation which I’ll paste the link in a short time. It not only checks all sort of errors and how to solve them step by step.

Mainly 2 kinds of errors are there:
1)

bundle exec rake autospec

  • This is running with error. I suggestion (IGNORE :slight_smile: and go to next step

bundle exec rails server

Then open http://localhost:3000/

bundle exec rake db:create
bundle exec rake db:migrate
RAILS_ENV=test bundle exec rake db:create db:migrate

This is the another problem of everyone. You can create step by step and make sure while any step is being executed, don’t press ENTER as it will halt the step.

Documentation will be uploaded shortly.

Hey everyone,

Here is the document for the installation procedure of discourse and debugging.

Please let me know if any else test cases to be added for Ubuntu installation.

Screen Shot 2020-05-29 at 12.03.18 AM

Hey guys, can anyone help me with this? After I ran the ‘bundle install’ command, this error showed up and I tried to run other commands but nothing worked so far. I also tried these lines like Vrinda said above, but nothing changed.
rvm install ruby-2.6
gem install bundler:2.1.4
bundle update --bundler

Hi, I have faced similar kind of issue. I saw this in Stack Overflow and this worked for me:

  1. In your Gemfile or wherever you have specified the gems list and replace source 'https://......' with this source 'http://.......' otherwise it will keep on asking Make sure that gem install gem_name__ v xxx' succeeds before bundling.`
  2. Do bundle install or rails new todo

I’ve been stuck here after I opened local host, opened new terminal window and did RAILS_ENV=development bundle exec rake admin:create . Screen Shot 2020-05-29 at 1.33.20 PM

Thanks in advance.

@Sai_Likhith_K I did not work for me even though I tried the same thing. The same error keeps appearing

Have you tried the

gem install cppjieba_rb -v ‘0.3.3’ --source ‘https://rubygems.org/

before you do bundle install @TamNguyen?